Social Media

Photos from Jukasa Motor Speedway's post by Facebook RSS
[Today at 05:17:47 PM]


Coach Fran by Facebook RSS
[Today at 05:17:37 PM]


Ronnie Johnson Wins Family Battle On The Valley?s High Banks For First Victory Of ?20 by Facebook RSS
[Today at 05:17:22 PM]


Lightning is in the house?? by Facebook RSS
[Today at 05:17:00 PM]


Photos from Can-Am Speedway's post by Facebook RSS
[Today at 05:16:50 PM]


56th Heath Memorial This Monday - 7 p.m. GREAT NEWS - All 30 Modified Laps Are Now Sold! We have plenty of laps in the Crate Sportsman, 600 Modified and Four Cylinder Expert Classes at this time. Thanks to the following latest lap sponsors to fill ou by Facebook RSS
[Today at 05:16:42 PM]


This Monday, August 10th is the 56th running of the Heath Memorial at Five Mile Point Speedway. Modifieds 30 laps - $2,000 to win. Racing begins at 7 p.m. The race can be seen live in it's entirety with a multi-camera broadcast on www.dirttrackd by Facebook RSS
[Today at 05:16:41 PM]


Northeast Paving & Sealcoating All-Star & Junior Slingshot Random Free Pass Drawings (Good for admission on August 16th, 2020) by Facebook RSS
[Today at 05:16:38 PM]


Glen Ridge Motorsports Park Lap Leaders By Division Through August 9, 2020. The Red Chair DIRTcar Racing 602 Crate Sportsman Cody Ochs - 41 Travis Green - 36 Tucker OConnor - 35 Scott McCoy - 30 Tony Farone - 30 Andrew Buff- 27 Ryan Heath - 23 Joe Orland by Facebook RSS
[Today at 05:16:38 PM]


Photos from Thunder Mountain Speedway's post by Facebook RSS
[Today at 05:15:37 PM]

Author Topic: 602 crate motor distributor problem  (Read 3210 times)

imca77

  • Rookie
  • **
  • Posts: 172
    • View Profile
602 crate motor distributor problem
« on: May 13, 2017, 12:16:24 PM »
can anybody tell me if they are having problems with the module's going bad in about 2 weeks, and  if so what has been the fix, or maybe we are missing something? have lost 2 in the past 2 weeks. battery is new, alt. putting out correctly, any ideas,thanks. 

MBM76

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: 602 crate motor distributor problem
« Reply #1 on: May 13, 2017, 03:14:05 PM »
I have had defective tachometers short out and kill modules. Also make sure your motor has a good ground, if your battery grounds goes to the frame or the cage, run a ground from the motor to the frame. When you replace the module make sure you put a good coating of heat transfer grease on the bottom of it. And use a good quality module, I have had cheap aftermarket modules from parts stores go bad in a short amount of time.

imca77

  • Rookie
  • **
  • Posts: 172
    • View Profile
Re: 602 crate motor distributor problem
« Reply #2 on: May 13, 2017, 03:34:16 PM »
any problem with the rev limiter affecting the modules? just asking, trying to cover everything. this is a dirt crate sportsman, teo rubber mounts.thanks.


MBM76

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: 602 crate motor distributor problem
« Reply #3 on: May 13, 2017, 04:07:18 PM »
I have never had a rev limiter itself short out and damage a module, but I have seen wiring going through the firewall rub and short out causing all sorts of weird issues.

imca77

  • Rookie
  • **
  • Posts: 172
    • View Profile
Re: 602 crate motor distributor problem
« Reply #4 on: May 13, 2017, 06:40:01 PM »
thanks for the input,we'll look at everything,thanks again.

John_unaman

  • Veteran
  • ***
  • Posts: 581
    • View Profile
Re: 602 crate motor distributor problem
« Reply #5 on: July 17, 2017, 09:17:56 PM »
I have had defective tachometers short out and kill modules. Also make sure your motor has a good ground, if your battery grounds goes to the frame or the cage, run a ground from the motor to the frame. When you replace the module make sure you put a good coating of heat transfer grease on the bottom of it. And use a good quality module, I have had cheap aftermarket modules from parts stores go bad in a short amount of time.

I would only add, the brand called ProComp seems to have more than it's share of issues, Tachometers are a big problem, I would leave disconnected. Good info from MBM76.


 

SimplePortal 2.3.7 © 2008-2020, SimplePortal